Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 70104 Accepted: 22060

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


分析:简单的bfs,水题.

code:

#include <cstdio>
#include <queue>
#include <iostream>
#include <cstring>

using namespace std;
typedef long long ll;
typedef struct{
    int x,time;
}data;
int vis[100005],ex;
data star;

void bfs()
{
    queue <data> q;
    q.push(star);
    
    while(q.size())
    {
        data now=q.front(),nex;
        q.pop();
        
        int a=now.x+1;
        if(now.x==ex)
        {
            cout<<now.time<<endl;
            return;
        }
        
        if( 0 <=a && a <= 100000 && vis[a]==0 )
        {
            nex.time=now.time+1;
            nex.x=a;
            vis[a]=1;
            q.push(nex);
        }
        a=now.x-1;
        if( 0 <=a && a <= 100000 && vis[a]==0 )
        {
            nex.time=now.time+1;
            nex.x=a;
            vis[a]=1;
            q.push(nex);
        }
        a=now.x*2;
        if( 0 <=a && a <= 100000 && vis[a]==0 )
        {
            nex.time=now.time+1;
            nex.x=a;
            vis[a]=1;
            q.push(nex);
        }
    }
}

int main(void)
{
    
    scanf("%d %d",&star.x,&ex);
    star.time=0;
    vis[star.x]=1;
    bfs();
}


Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐