题目:

Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8100 Accepted: 2221

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28


题目大意:给你一组数,保证是升序排列。分成两组组成两个不同的数,使其差最小。

思路:最多只有十个数,生成全排列后从中间分隔成两个数,再选最小差就行。注意除非那个数本身就是0,否则不能以0开头!!!    


代码如下

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <cctype>
#include <string>
#include <map>
#include <iostream>
using namespace std;

#define INF 1e9+7
#define MAXN 100010

int a[15];

int shift(int i,int j)
{
    int s=0;
    for(int k=i;k<=j;k++)
    {
        s=s*10+a[k];
    }
    return s;
}


int main()
{
    int t;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        int minn=INF;
        char temp[30];
        gets(temp);
        int n=(int)strlen(temp);
        int m=0;
        for(int i=0;i<n;i++)
            if(isdigit(temp[i]))
                a[m++]=temp[i]-'0';
        do{
            for(int k=m/2;k<=m/2+1;k++)
            {
                int s1=shift(0, k-1);
                int s2=shift(k, m-1);
                if((s1!=0&&a[0]==0)||(s2!=0&&a[k]==0))
                    continue;
                minn=min(minn,abs(s1-s2));
            }
        }while(next_permutation(a, a+m));
        printf("%d\n",minn);
    }
}





Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐