Image Perimeters
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8594 Accepted: 5145
Description

Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected objects.

The digitized slides will be represented by a rectangular grid of periods, ‘.’, indicating empty space, and the capital letter ‘X’, indicating part of an object. Simple examples are

XX Grid 1 .XXX Grid 2

XX .XXX

              .XXX 

              ...X 

              ..X. 

              X... 

An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X’s overlap on an edge or corner, so they are connected.

XXX

XXX Central X and adjacent X’s

XXX

An object consists of the grid squares of all X’s that can be linked to one another through a sequence of adjacent X’s. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square. The remaining X’s belong to the other object.

The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3.

One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure at the left. The length is 18.

Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear:

Impossible Possible

XXXX XXXX XXXX XXXX

X..X XXXX X… X…

XX.X XXXX XX.X XX.X

XXXX XXXX XXXX XX.X

….. ….. ….. …..

..X.. ..X.. ..X.. ..X..

.X.X. .XXX. .X… …..

..X.. ..X.. ..X.. ..X..

….. ….. ….. …..
Input

The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line, consisting of ‘.’ and ‘X’ characters.

The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks.
Output

For each grid in the input, the output contains a single line with the perimeter of the specified object.
Sample Input

2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
…X
..X.
X…
5 6 1 3
.XXXX.
X….X
..XX.X
.X…X
..XXX.
7 7 2 6
XXXXXXX
XX…XX
X..X..X
X..X…
X..X..X
X…..X
XXXXXXX
7 7 4 4
XXXXXXX
XX…XX
X..X..X
X..X…
X..X..X
X…..X
XXXXXXX
0 0 0 0
Sample Output

8
18
40
48
8
题意:直接解释输入输出了。。(手懒)输入4个数字,前两个数字n,m代表输入一个n行m列的点阵,后两个数字代表从(sx,sy)开始扩散。
找出与sx,sy连通的点的周长(以八个方向扩散)
这道题必须看这个图!!!!这里写图片描述看完这个图顿时感觉思路明确。
思路:
只要找连通的所有的”X”四个方向不是“X”的点的总和就好啦。(见代码)

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
queue<int> p,q;
int n,m,sx,sy,yyy[]={1,-1,0,0},xxx[]={0,0,1,-1},ans=0;
char a[100][100];
bool vis[100][100];
void bfs()
{
    while(!p.empty())
    {
        int tempx=p.front(),tempy=q.front();
        p.pop();q.pop();
        for(int i=0;i<=3;i++)
            if(a[xxx[i]+tempx][yyy[i]+tempy]!='X')ans++;
        for(int i=-1;i<=1;i++)
            for(int j=-1;j<=1;j++)
                if(i!=0||j!=0)
                {
                    int ex=tempx+i,ey=tempy+j;
                    if(a[ex][ey]=='X'&&!vis[ex][ey])
                    {
                        p.push(ex);q.push(ey);vis[ex][ey]=1;
                    }
                }
    }
}
int main()
{
    while(scanf("%d%d%d%d",&n,&m,&sx,&sy)&&n)
    {
        memset(vis,0,sizeof(vis));ans=0;
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                cin>>a[i][j];
        p.push(sx);q.push(sy);vis[sx][sy]=1;
        bfs();
        printf("%d\n",ans);
    }
}

这里写图片描述

转载于:https://www.cnblogs.com/SiriusRen/p/6532503.html

Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐