Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

 

/* water..
 */
#include "iostream"
#include "cstring"
#include "stack"
using namespace std;
char num[10][6] = { "zero","one","two","three","four","five","six","seven","eight","nine" };
int  main() {
    stack<int>s;
    char str[101];
    int sum = 0;
    cin >> str;
    for (int i = 0; i < strlen(str);i++) {
        sum += str[i] - '0';
    }
    if (sum == 0) {
        cout << "zero" << endl;
        return 0;
    }
    while (sum != 0) {
        s.push(sum % 10);
        sum /= 10;
    }
    int k = 1;
    while (!s.empty()) {
        if(k == 1)
        cout<<num[s.top()];
        else
        cout << " "<<num[s.top()];
        s.pop();
        k++;
    }
    cout << endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/minesweeper/p/6275134.html

Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐