一、题目

Description

Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something. 
Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say. 
Input all the square Wangpeng draws, what’s the number in the picture?
 

Input

There are multiple test cases. 
For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares. 
Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap. 
Input ends with N = 0.
 

Output

For each case, output the total area in one line.
 

Sample Input

4
1 2 3 4
3
3 3 3
0
 

Sample Output

30
27
二、题目源代码
#include<iostream>
using namespace std;
int main()
{
    int i,n,sum,a;
    cin>>n;
    while(n)
    {
        sum=0;
        for(i=0;i<n;i++)
        {
            cin>>a;
            sum+=a*a;
        }
        cout<<sum<<endl;
        cin>>n;
    }

    return 0;
}

三、心得体会

这是一道超级无敌大水题,本来是不用写解题报告的,可是我还是必须要写一下。因为在比赛的时候,我提交了两次这道题都没有AC,可是我觉得我做的挺对的,就继续做后面的了。到最后也没有AC.

为什么?

不认真读题!我没有注意到题目中说的 可以输入多组数据

关于输入输出我还存在很大的不足,之后做题的过程中一定要注意!!

 

 
 
 

转载于:https://www.cnblogs.com/fightfor/p/3855129.html

Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐