【PAT】1024.Palindromic Number (25)
题目描述A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic n..
题目描述
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
翻译:一个数字如果反序和正序相同,则称作回文数。举个例子,1234321是一个回文数。所有的一位数都是回文数。
非回文数可以通过一系列变换转变成回文数。第一步,将非回文数翻转然后将结果加到上面。如果还不是回文数,则重复此操作直到它是一个回文数。举个例子,如果我们从67开始,我们可以通过以下两步转换为回文数:67 + 76 = 143, 143 + 341 = 484。
INPUT FORMAT
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.
翻译:一个输入文件包括一组测试数据。每组测试数据包括两个正整数N和K,N(<= 10^10)是初始数,K(<= 100)是最大步数。数字之间用空格隔开。
OUTPUT FORMAT
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
翻译:对于每组输入数据,输出两个数字,一个一行。第一个数字是得到的回文数N,第二个数字是得到回文数的步数。如果知道K次结束都没有发现回文数,就输出K步后的数字和K次变换。
Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3
解题思路
跟上题做法一样,用字符数组保存数据,再转化为数字数组,注意倒序保存,不然进位会出错。然后倒序相加,如果回文就退出,否则进行K次重复变换。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int length,a[110],b[110],K;
char s[15];
void Copy(){
for(int i=0;i<length;i++){
b[i]=a[length-1-i];
}
}
void print(){
for(int i=0;i<length;i++)
printf("%d",a[length-1-i]);
printf("\n");
}
void Plus(){
for(int i=0;i<length;i++){
a[i]+=b[i];
if(a[i]>=10){
a[i+1]++;
a[i]%=10;
}
}
if(a[length])length++;
}
int Judge(){
for(int i=0;i<length/2;i++){
if(a[i]!=a[length-1-i])return 0;
}
return 1;
}
int main(){
scanf("%s%d",s,&K);
length=strlen(s);
for(int i=0;i<length;i++)a[i]=s[i]-'0';
int k=K;
while(k){
if(Judge())break;
Copy();
Plus();
k--;
}
print();
printf("%d\n",K-k);
return 0;
}
开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!
更多推荐
所有评论(0)