find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13696    Accepted Submission(s): 4209


Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

Output
对于每个N,输出S中第N个对应的数字.
 

Sample Input
  
  
6 1 2 3 4 5 10
 

Sample Output
  
  
1 1 2 1 2 4
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    long long n,i,t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=1; i<n; i++) //求的是n终极落在Sn区间上,且Sn有n个数;
        {
            n-=i;
            //printf("%d\n",n);
        }
        printf("%d\n",n);
        n=n%9;//每9个轮回一次;
        if(n)
            cout<<n<<endl;
        else
            cout<<9<<endl;
    }
}


Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐