Have Fun with Numbers (玩数字) java
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number con
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
/*数字比较大,要用BigInteger来完成*/
import java.math.BigInteger;
import java.util.Scanner;
public class Main{
public static void main(String[] args) {
int[] count1 = new int[10];
int[] count2 = new int[10];
Scanner sc=new Scanner(System.in);
String str=sc.next();
sc.close();
BigInteger bi=new BigInteger(str);
bi=bi.multiply(new BigInteger("2"));
String newstr=bi.toString();
if(newstr.length()!=str.length()) {
System.out.println("No");
System.out.println(newstr);
return;
}
for(int i=0;i<str.length();i++) {
count1[str.charAt(i)-'0']++;
}
for(int i=0;i<newstr.length();i++) {
count2[newstr.charAt(i)-'0']++;
}
for(int i=0;i<10;i++) {
if(count1[i]!=count2[i]) {
System.out.println("No");
System.out.println(newstr);
return ;
}
}
System.out.println("Yes");
System.out.println(newstr);
}
}
开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!
更多推荐
所有评论(0)