Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N(1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space.

Sample Input 

2 
3 
13

Sample Output 

0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1

 Status




#include<stdio.h>
#include<string.h>
int main (void)
{
    int T,num;
    int c[15];
    scanf("%d",&T);
    while(T--)
    {
        memset(c,0,sizeof(c));
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            int ii=i;
            while(ii)//这里是个小技巧
            {
                num=ii%10; 
                ii/=10;
                c[num]+=1;
            }
        }
        for(int i=0;i<=9;i++)
        {
            if(i==0)
            printf("%d",c[i]);
            else
            printf(" %d",c[i]);
        }
        printf("\n");

    }
    return 0;
}




Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐