Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31058    Accepted Submission(s): 9544


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
 

Source
 

分析:这里利用到了一点数论的小知识,像24,2和4相加%9=6,像39,3和9相加%9=3,所以我们不必要分多次计算那样时间会超

代码:

#include<stdio.h>
int main()
{
    char dig[1024];
    while(scanf("%s",dig)&&dig[0]!='0')
    {
        int sum=0;
        int i;
        for(i=0;dig[i]!='\0';i++)
            sum+=dig[i]-'0';
        printf("%d\n",sum%9==0?9:sum%9);
    }
    return 0;
}

Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐