http://poj.org/problem?id=3191

The Moronic Cowmpouter
Time Limit:1000MS Memory Limit:65536K

Description

Inexperienced in the digital arts, the cows tried to build a calculating engine (yes, it's a cowmpouter) using binary numbers (base 2) but instead built one based on base negative 2! They were quite pleased since numbers expressed in base −2 do not have a sign bit.

You know number bases have place values that start at 1 (base to the 0 power) and proceed right-to-left to base^1, base^2, and so on. In base −2, the place values are 1, −2, 4, −8, 16, −32, ... (reading from right to left). Thus, counting from 1 goes like this: 1, 110, 111, 100, 101, 11010, 11011, 11000, 11001, and so on.

Eerily, negative numbers are also represented with 1's and 0's but no sign. Consider counting from −1 downward: 11, 10, 1101, 1100, 1111, and so on.

Please help the cows convert ordinary decimal integers (range -2,000,000,000..2,000,000,000) to their counterpart representation in base −2.

Input

Line 1: A single integer to be converted to base −2

Output

Line 1: A single integer with no leading zeroes that is the input integer converted to base −2. The value 0 is expressed as 0, with exactly one 0.

Sample Input

-13

Sample Output

110111

Hint

Explanation of the sample:

Reading from right-to-left:
1*1 + 1*-2 + 1*4 + 0*-8 +1*16 + 1*-32 = -13
此题的解法基于以下几点:
(1) 如果一个数是奇数,那么它的二进制形式的最后一位肯定是1,我们可以去掉此 1,就是(x-1)/-2,进入(2)
(2) 如果一个数的最后一位为 0 ,我们可以把这个数右移(可以类比以 2 为基的二进制数的操作)一位,然后它的
二进制的倒数第二个数就成了最后一个,就是 x=x/-2,然后进入(1)迭代,直到变为 0
/* Author : yan
 * Question : POJ 3191 The Moronic Cowmpouter
 * Date && Time : Saturday, January 22 2011 08:43 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
int value;
char cache[100];
int cnt;
void reverse()
{
	int i;
	char tmp;
	for(i=0;i<cnt/2;i++)
	{
		tmp=cache[cnt-i-1];
		cache[cnt-i-1]=cache[i];
		cache[i]=tmp;
	}
}
int main()
{
	//freopen("input","r",stdin);
	scanf("%d",&value);
	if(value==0)
	{
		printf("0");
		goto end;
	}
	while(value!=1)
	{
		if(abs(value)%2!=0)
		{
			cache[cnt++]='1';
			value=(value-1)/(-2);
		}
		else
		{
			cache[cnt++]='0';
			value=value/(-2);
		}
	}
	reverse();
	cache[cnt]='/0';
	printf("1%s",cache);
	end:;
	return 0;
}

Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐