开放原子开发者工作坊 1069 The Black Hole of Numbers (20分)

1069 The Black Hole of Numbers (20分)

题目地址For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be ...

vincewm  ·  2019-12-25 23:15:26 发布

题目地址

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10
​4
​​ ).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767

Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:
2222

Sample Output 2:
2222 - 2222 = 0000

#include <iostream>
#include <vector>
#include<algorithm>
#include <cmath>
#include<map>
#include<cstring>
#include<queue>
#include<string>
#include<set>
#include<stack>
using namespace std;
typedef long long ll;
const int maxn=110,inf=100000000;
int main(){
    string s1,s2;
    cin>>s1;
    s1.insert(0,4-s1.length(),'0');
    do{
        sort(s1.begin(),s1.end());s2=s1;
        reverse(s2.begin(),s2.end());
        int num=stoi(s2)-stoi(s1);
        string s3=to_string(num);
        s3.insert(0,4-s3.length(),'0');
        cout<<s2<<" - "<<s1<<" = "<<s3<<endl;
        s1=s3;
    }while(s1!="6174"&&s1!="0000");         //输入时6174的话还要便利的;
}
Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐

  • 浏览量 48
  • 收藏 0
  • 0

所有评论(0)

查看更多评论 
已为社区贡献1条内容