Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

  • Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

  • Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

  • Sample Input:
    12345
  • Sample Output:
    one five
#include <iostream>
#include <string>
#include <map>
using namespace std;

map<int, string> IntToString {
    {0, "zero"},
    {1, "one"},
    {2, "two"},
    {3, "three"},
    {4, "four"},
    {5, "five"},
    {6, "six"},
    {7, "seven"},
    {8, "eight"},
    {9, "nine"}
};

int main() {
    string num;
    cin >> num;
    int sum = 0;
    for (auto digit : num)  // auto 遍历 string 类型变量
        sum += static_cast<int>(digit) - '0';   // 或者 -48

    num = std::to_string(sum);  // int to string 的转换
    cout << IntToString[static_cast<int>(num[0] - '0')];
    for (auto digit : num) {
        if (digit != num[0])
            cout << " " << IntToString[static_cast<int>(digit - '0')];
    }
    cout << endl;

    return 0;
}
Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐