Rightmost Digit

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45421    Accepted Submission(s): 17090

 

 

 

Problem Description

 

 

Given a positive integer N, you should output the most right digit of N^N.
 

 

Input

 

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output

 

For each test case, you should output the rightmost digit of N^N.
 

 

Sample Input

 

 
2 3 4
 

 

Sample Output

 

 
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

 

Author

 

Ignatius.L
 
 
#include <bits/stdc++.h>
using namespace std;
long long power_mod(long long a, long long b, long long c)
{
long long ans = 1;
a = a % c;
while(b>0)
{
if(b&1)
ans = (ans * a) % c;
b = b>>1;
a = (a * a) % c;
}
return ans;
}
int main()
{
	int T;
	scanf("%d",&T);
    while(T--){
    	long long t ;
    	scanf("%I64d",&t);
    	printf("%I64d\n",power_mod(t,t,10));
    }
	return(0);
}

 

Logo

开放原子开发者工作坊旨在鼓励更多人参与开源活动,与志同道合的开发者们相互交流开发经验、分享开发心得、获取前沿技术趋势。工作坊有多种形式的开发者活动,如meetup、训练营等,主打技术交流,干货满满,真诚地邀请各位开发者共同参与!

更多推荐