Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 219497 Accepted: 66357
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source

USACO 2007 Open Silver

分析:

bfs广度优先遍历 应用队列

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int n,k,flag,sum,j;
int v[100010],b[100010];
string s,c;
struct info{
	int pos;
	int time;
};
queue<info> q;
int main(){//广度优先遍历第一次找到的一定是最短的路径 
	cin>>n>>k;
	memset(v,0,sizeof(v));
	info first;
	first.pos=n;
	first.time=0;
	v[first.pos]=1;
	q.push(first);
	while(!q.empty()){
		info c=q.front();
		q.pop();
		if(c.pos==k){
			cout<<c.time<<endl;
			break;
		}
		info next;
		if(c.pos-1>=0&&c.pos-1<=100000&&v[c.pos-1]==0){
			next.pos=c.pos-1;
			next.time=c.time+1;
			q.push(next);
			v[next.pos]=1;
		} 
		if(c.pos+1>=0&&c.pos+1<=100000&&v[c.pos+1]==0){
			next.pos=c.pos+1;
			next.time=c.time+1;
			q.push(next);
			v[next.pos]=1;
		} 
		if(c.pos*2>=0&&c.pos*2<=100000&&v[c.pos*2]==0){
			next.pos=c.pos*2;
			next.time=c.time+1;
			q.push(next);
			v[next.pos]=1;
		} 
		
	}
	return 0;
}
Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐