Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

代码: 

#include<iostream>
using namespace std;
int main()
{
    char N;
    string num[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
    int i=0,sum=0,temp[10];
    scanf("%c",&N);
    do
    {
        sum+=(N-'0');
        scanf("%c",&N);
    }while(N!='\n');
    while(sum)
    {
        temp[i++]=sum%10;
        sum/=10;
    }
    if(i==0)
        printf("zero");
    else
    {
        i--;
        while(i)
            cout<<num[temp[i--]]<<" ";
        cout<<num[temp[0]];
    }
    return 0;
}

 

Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐